## Contents

Chapter 1. About Documentation ................................................................. 1  
  1.1. Documentation for PROMT for SDL Trados ........................................ 1  
  1.2. Conventions ................................................................................. 2  
  1.3. Getting Help and Technical Support ............................................... 3  
     1.3.2. Technical Support .................................................................. 3  
Chapter 2. Introduction .............................................................................. 4  
  2.1. About PROMT for SDL Trados .......................................................... 4  
  2.2. Key Concepts .................................................................................. 5  
  2.3. Working with PROMT for SDL Trados ............................................ 6  
Chapter 3. Working with Plug-In in SDL Trados Studio 2015 .................. 7  
  3.1. Activating Plug-in in SDL Trados Studio .......................................... 7  
  3.2. Creating a Project in SDL Trados Studio 2015 .................................. 8  
     3.2.1. Customizing PROMT Translator (PTS) ..................................... 10  
     3.2.2. Customizing Search in Translation Memory .............................. 11  
     3.2.3. Customizing Batch Processing .............................................. 12  
  3.3. Editing Translation Results ............................................................... 13  
  3.4. Updating Translation Memory ........................................................... 17  
Chapter 4. Working with Plug-in in SDL Trados Studio 2019 .............. 18  
  4.1. Activating Plug-in in SDL Trados Studio .......................................... 18  
  4.2. Creating a Project in SDL Trados Studio 2019 .................................. 19  
     4.2.1. Customizing PROMT Translator (PTS) ..................................... 23  
     4.2.2. Customizing Search in Translation Memory .............................. 25  
     4.2.3. Customizing Batch Processing .............................................. 26  
  4.3. Editing Translation Results ............................................................... 28  
  4.4. Updating Translation Memory ........................................................... 32
Chapter 1. About Documentation

1.1. Documentation for PROMT for SDL Trados

This User’s Guide describes the main possibilities of the PROMT for SDL Trados plug-in and contains information about its working in the SDL Trados Studio environment and updating the Translation Memory (TM) databases by the results of machine translation performed by the PROMT translator.

For more information about working with translator, see the User’s Guide for PROMT Translation Server 21 or PROMT Neural Translation Server 21.

For more information about SDL Trados Studio, see its own User’s Guide or Help.
1.2. Conventions

The following icons are used to identify some conventions in this Guide:

- ? — tips and recommendations which provide helpful information;
- ! — important notes or cautions;
- ✱ — notes or additional information that require special attention;
- ➤ — steps the user needs to follow;
- ✪ — result of the user’s task;
- 🔗 — link to detailed information in the User’s Guide or Help.
1.3. Getting Help and Technical Support

1.3.2. Technical Support

If you run into a problem with your copy of PROMT translator, please contact our technical support by phone, or send a fax or an email. When submitting your issue, please specify the following:

• your PROMT translator license number;
• specialized dictionaries and language pairs you use with your translator;
• basic hardware specifications of your computer, such as processor type, how much RAM and free hard disk space you have, and whether you are using a network interface;
• basic software specifications, such as the version of your Windows operating system, installed service packs, localization and regional settings;
• brief description of your problem and what you did before the problem occurred;
• brief descriptions of the steps you took to try to address the problem;
• the exact text or a screenshot of any error message you received.

When calling the technical support by phone, please be in front of your computer.
Chapter 2. Introduction

2.1. About PROMT for SDL Trados

PROMT for SDL Trados is an extension for SDL Trados Studio, which allows you to automatically translate segments not found in the translation memories of the SDL Trados Studio application and replenish the translation memories.

For translation, PROMT for SDL Trados uses PROMT Translation Server 21 or PROMT Neural Translation Server 21 (PTS) — a client–server system for machine translation.

⚠️ To work with PROMT for SDL Trados extension, make sure that PTS (PROMT Translation Server 21 or PROMT Neural Translation Server 21) is installed and activated on your computer.

⚠️ To install PROMT for SDL Trados extension, please address the PTS administrator.

The following versions of SDL Trados Studio are supported:

• SDL Trados Studio 2015
• SDL Trados Studio 2017
• SDL Trados Studio 2019
• SDL Trados Studio 2021

⚠️ Chapter 3 of this User’s Guide describes the work with PROMT for SDL Trados plug-in on example of SDL Trados Studio 2015, and chapter 4 describes on example of SDL Trados Studio 2019. In other versions of SDL Trados Studio there may be differences in interface elements, but the main steps during the work with extension are similar.
2.2. Key Concepts

To take full advantage of the capabilities of PROMT for SDL Trados translator you should familiarize yourself with the key concepts below.

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Language Pair</td>
<td>Specifies from which language and into which language the text will be translated.</td>
</tr>
<tr>
<td>Translation Profile</td>
<td>A set of saved linguistic settings available from all applications of the PROMT suite that can be configured to translate texts for a specific subject or field.</td>
</tr>
<tr>
<td>Translation Memory (TM)</td>
<td>A database that stores translation units which consist of a source segment (typically, a sentence) and its target, translated segment counterpart. During translation, segments of the source text that is to be translated are compared to the contents of the Translation Memory. If they match completely, then the corresponding translation is used from the Translation Memory.</td>
</tr>
</tbody>
</table>
2.3. Working with PROMT for SDL Trados

The work with PROMT for SDL Trados consists of the following stages:

1. Creating a project in SDL Trados Studio. This stage includes:
   a. Selecting a source language and one or more target languages.
   b. Importing files for translation (includes segmentation, i.e. splitting the texts into fragments for translation).
   c. Enabling translation memories and extensions for machine translation in the project.

2. Preliminary batch translation. This stage includes:
   a. Comparing segments of text in selected documents with the segments saved in the translation memories of the SDL Trados Studio application.
   b. Translation of segments not found in the translation memories with PROMT translator.

3. Editing the results of automatic translation in interactive mode (marked AT – Automated Translation).

4. Completing the project. This stage includes:
   a. Exporting translated documents into the source format.
   b. Replenishing the translation memories with new segments with edited translations.

For more details about working with PROMT for SDL Trados see next sections.
Chapter 3. Working with Plug-In in SDL Trados Studio 2015

3.1. Activating Plug-in in SDL Trados Studio

Before you start translating documents in SDL Trados Studio with the help of the PROMT for SDL Trados plug-in, make sure that this plug-in is successfully activated and can be used in SDL Trados Studio.

Launch SDL Trados Studio, click Manage Plug-ins on the Add-Ins tab, and make sure that the PROMT for SDL Trados (PTS) checkbox is checked in the Plug-ins dialog box.

The Plug-ins dialog box displays a list of plug-ins which can be currently used in SDL Trados Studio. To activate a plug-in, select the appropriate checkbox. To deactivate a plug-in, deselect its checkbox.

After the installation, the PROMT for SDL Trados (PTS) checkbox is automatically checked in the Plug-ins dialog box.
3.2. Creating a Project in SDL Trados Studio 2015

To use PROMT for SDL Trados, you need to create a project in SDL Trados Studio and customize it appropriately. New translations projects are created using the New Project wizard.

To start the wizard, select File > New > New Project (Ctrl+N) or click Create New Project on the Home tab of the Projects view.

The New Project wizard is displayed. Follow the onscreen instructions:

- click Next to go to the next step;
- click Back to go to the previous step;
- click Finish to finish the process.

For more detailed instructions on any of the steps of creating and customizing a project, refer to the topics in SDL Trados Studio Help.

The steps which are necessary for enabling the PROMT for SDL Trados plug-in in the project are listed below.

1. On the Project Type page specify if you want to base your project on a template or a previous project.
2. On the Project Details page enter basic project details.
3. On the Project Languages page specify your source language (the language from which you are translating) and the target languages (the languages into which you are translating).

   If you specify several target languages in the project, definite language pair should be selected for text translation.

4. On the Project Files page select your project files.
   Click File Types to view the list of supported files types.

5. On the “Translation Memory and Automated Translation” page click Add and select your translation resources for the language pairs of the project:
   - Translation Memories — for using existing translations from the translation memories;
     Specify your translation memory search settings. For more information about translation memory search settings, see 3.2.2. “Customizing Search in Translation Memory” on page 11.
   - PROMT Translator (PTS) provider — for automated translation with PTS (client–server system for machine translation).

In SDL Trados Studio translation plug-ins are called providers.
3.2. Creating a Project in SDL Trados Studio 2015

Customize main translation settings for the selected provider.

- When you select PROMT Translator (PTS) for the first time, the Settings dialog box is automatically displayed, where you should customize connection to the PTS server and select main translation settings. For more information about customizing the PROMT Translator (PTS) provider, see 3.2.1. “Customizing PROMT Translator (PTS)” on page 10.

- By default, all settings are set for all language pairs in the All Language Pairs section. If you have several language pairs in the project, you can set personal settings for each of them.

6. On the Project Preparation page select the preparation steps (tasks) to be performed on the files of the newly created project.

7. On the Batch Processing Settings page specify what settings are applied when the batch processing task is performed.

- For more information about batch processing settings, see 3.2.3. “Customizing Batch Processing” on page 12.

8. The Preparing Project page is displayed whilst your project is being created. Progress bars indicate what task the process has reached.

- When all of the tasks have been completed on the Preparing Project page and the project has been created, the Project Template settings are displayed. Specify if you want to save the project settings for future use in a template.
9. Click Close to exit the New Project wizard.

   The Close button is not active until the project is created. If a project was not created due to errors in the tasks, this button remains inactive. Click Back to change the settings and restart the creating process.

3.2.1. Customizing PROMT Translator (PTS)

To customize main translation settings, select a provider on the Translation Memory and Automated Translation page and click Settings.

On the Connection Settings tab of the Settings dialog box specify the PTS connection string and, if necessary, authentication data which are used for connecting to PTS, or proxy server data, if you connect to PTS via a proxy server.

![Settings dialog box](image)

Fig. 3.3. Customizing connection to the PTS server

To get the PTS connection string please address to your server administrator. Administrator, in turn, can get it from IIS.

The PTS connection string should be in the following format: \http://<server name or IP-address>/<name of XLIFF-service web application>/ptxllftranslator.asmx.

To work with the PROMT for SDL Trados extension, you need the installed and customized XLIFF web service. The process of installation and customization of this component is described in PTS Administrator’s Guide.
3.2.2. Customizing Search in Translation Memory

On the Translation Settings tab of the Settings dialog box select the main translation settings that should be used in this project:

PROMT Translator (PTS) provider supports translation for the language pairs included into the PTS set.

If you had already customized connection to the PTS server for the PROMT Translator (PTS) provider, then this provider can be added only to those SDL Trados projects, at least one language pair of which is supported on the selected PTS server.

For creating and editing translation profiles, use the PTS tools. For more information about working with translator, see the PTS User’s Guide.

3.2.2. Customizing Search in Translation Memory

To specify the settings for translation memory lookup and concordance searching, select Search on the “Translation Memory and Automated Translation” page and in the Translation group specify the necessary options:

• “Minimum match value” — the degree of match that must exist between a source document segment and a translation memory segment in order for the segment translation to be offered as a match.

  The default is 70%.

• “Maximum number of hits” — the maximum number of translation memory matches that will be returned from a lookup.

  The default is 5.
Chapter 3. Working with Plug-In in SDL Trados Studio 2015

- “Look up segments in MT even if a TM match has been found” — enable this option, if you want to receive both translation memories and machine translation results. By default, SDL Trados Studio resorts to machine translation providers only if your selected translation memories do not generate any results.

SDL Trados Studio prioritizes your selected translation providers by the order you defined on the “Translation Memory and Automated Translation” page. In general, keep machine translation providers at the bottom of your list of translation providers for best and fastest lookup strategy. This ensures that translation memory matches are generally looked up first and machine translation providers are used only when needed, depending on your other settings.

For more information about other settings, see SDL Trados Studio User’s Guide or Help.

3.2.3. Customizing Batch Processing

To specify the settings control how the translation memories are applied to the project files when you run the Pre-translate batch task, select Pre-translate Files on the Batch Processing Settings page and specify the necessary options.

This batch task is performed by default when you create a project.

- “Minimum match value” in the Pre-translate Settings group — the degree of match that must exist between a source document segment and a segment in the translation memory, in order for the segment-translation in the translation memory to be applied to the document segment.

You may want to set this at a higher figure than you would use when you are applying translation memory interactively during document translation. For example, you may want to pre-translate a file at a much higher value (for example, 100%) instead of the more usual figure of 75% used for interactive translation memory lookups.

- “Apply automated translation” in the “When no match found” group — if none of your selected translation memory generates a TM match that meets the “Minimum match value”, SDL Trados Studio inserts translation results from the machine translation providers listed on the “Translation Memory and Automated Translation” page.

This option is available only if you already added machine translation providers.

For more information about other settings, see SDL Trados Studio User’s Guide or Help.
3.3. Editing Translation Results

To view the results of the preliminary batch translation, select Files in the left part of the screen and double-click the necessary file.

![Image of file details](image)

**Fig. 3.5. File Details**

In the lower part of the opened window you can see the results of the preliminary batch translation with the help of enabled translation memories and the PROMT Translator (PTS) provider.

If enabled translation memories did not generate any results and the segments were translated by the translation provider, the pane with translation looks like the following:
Chapter 3. Working with Plug-In in SDL Trados Studio 2015

Fig. 3.6. Translation Results

If some segments were found in the enabled translation memories and other were translated by the translation provider, the pane with translation looks like the following:
3.3. Editing Translation Results

In the Translation Results pane you can compare all variants of translation of the current segment, received from Translation Memories and translated by the provider, and select the most appropriate translation.

An icon between the source and target segments displays the actual match value for the segment from the Translation Memory, or AT (Automated Translation). If you place the mouse cursor on the icon, a tooltip appears which displays the details of translation:

• Status — current status of the segment;
• Origin — source of translation (Translation Memory or Automated Translation);
• System — TM name or the name of translation provider;
• Score — percent of match.

You can edit the results of translation in interactive mode or save them in bilingual format and send to external editor for reviewing.

• To save the translation of the document in a file, select File > Save Target As (Shift+F12) and specify the file name.
Chapter 3. Working with Plug-In in SDL Trados Studio 2015

- To save the results of translation in bilingual format, click “Export for External Review” on the Review tab.
  
  The thus saved file can be sent for reviewing to the external editor who may not have the installed SDL Trados Studio.

- To load the edited by the external editor bilingual file, click “Update from External Review” on the Review tab.
3.4. Updating Translation Memory

To update the translation memory with translations from the active document, do the following:

1. Click Batch Tasks on the Home tab of the Projects view and select Update Main Translation Memories.

2. On the Translation Memory Updates page:
   - select which translations should be added to the translation memory. This defaults to segments that are fully translated and approved;
   - select whether the translation should be added as new translation units or replace an existing translation unit.

3. Click Finish and wait till the process of translation memory updating is finished.

4. Click Close.

Before updating the translation memory make sure that Update checkbox is checked on the “Translation Memory and Automated Translation” page.
Chapter 4. Working with Plug-in in SDL Trados Studio 2019

4.1. Activating Plug-in in SDL Trados Studio

Before you start translating documents in SDL Trados Studio with the help of the PROMT for SDL Trados plug-in, make sure that this plug-in is successfully activated and can be used in SDL Trados Studio.

Launch SDL Trados Studio, click on the Add-ins tab, and make sure that the PROMT for SDL Trados (PTS) checkbox is checked in the Plug-ins dialog box.

![Plug-ins dialog box](image)

The Plug-ins dialog box displays a list of plug-ins which can be currently used in SDL Trados Studio. To activate a plug-in, select the appropriate checkbox. To deactivate a plug-in, deselect its checkbox.

After the installation, the PROMT for SDL Trados (PTS) checkbox is automatically checked in the Plug-ins dialog box.
4.2. Creating a Project in SDL Trados Studio 2019

To use PROMT for SDL Trados, you need to create a project in SDL Trados Studio and customize it appropriately. For this:

In the SDL Trados Studio, select File > New > New Project (Ctrl+N) or click New Project in the Projects group on the Home tab.

The “Create a New Project” wizard is displayed. Follow the onscreen instructions:
• click Next to go to the next step;
• click Back to go to the previous step;
• click Finish to finish the process.

For more detailed instructions on any of the steps of creating and customizing a project, refer to the topics in SDL Trados Studio Help.

The steps which are necessary for enabling the PROMT for SDL Trados plug-in in the project are listed below.

1. On the One Step page do the following:
   a. Specify if you want to base your project on a default template or on a previous project.
   b. Specify the name of the project and its location.
   c. Specify the source language (the language from which you are translating) and one or several target languages (the languages into which you are translating).
   
   ▶ If you specify several target languages in the project, definite language pair should be selected for text translation.
   
   d. Select your project files (separate files or all files from the definite folder) and make sure that all file types are correctly identified.

   ▶ Click File Type Identifier to view the list of supported files types.
Chapter 4. Working with Plug-in in SDL Trados Studio 2019

2. On the General page you may specify the description and additional project settings.

3. On the Translation Resources page do the following:
   a. To create a new translation memory, click Create and follow the onscreen instructions.
   b. To enable the tools of automated translation, click Use and select the existing tools of automated translation for the project language pairs:
      • Translation Memories — for using existing translation memories;
      • PROMT Translator (PTS) provider — for automated translation with PTS (client–server system for machine translation).

   ⚠ In SDL Trados Studio translation plug-ins are called providers.
4.2. Creating a Project in SDL Trados Studio 2019

![Image of the Translation Resources window]

**Fig. 4.3. Translation providers**

- **c. Customize main translation settings for the selected provider.**
  - When you select PROMT Translator (PTS) for the first time, the Settings dialog box is automatically displayed, where you should customize connection to the PTS server and select main translation settings. For more information about customizing the PROMT Translator (PTS) provider, see **4.2.1. “Customizing PROMT Translator (PTS)” on page 23.**
  - By default, all settings are set for all language pairs in the All Language Pairs section. If you have several language pairs in the project, you can set personal settings for each of them.

- **d. Customize the main settings of searching in translation memory.**
  - For more information about customizing the search in translation memory, see **4.2.2. “Customizing Search in Translation Memory” on page 25.**

- SDL Trados Studio prioritizes your selected translation providers by the order you defined on the Translation Resources page. In general, keep machine translation providers at the bottom of your list of translation providers for best and fastest lookup strategy. This ensures that translation memory matches are generally looked up first and machine translation providers are used only when needed, depending on your other settings.
Chapter 4. Working with Plug-in in SDL Trados Studio 2019

Fig. 4.4. Translation Resources page

4. On the Termbases page enable terminology databases, if necessary.

5. On the Trados GroupShare page specify additional settings for the server projects, if necessary.

6. On the Perfect Match page specify the possibility to use translations from the previous versions of the bilingual files, if necessary.

7. On the Batch Tasks page click Batch Tasks and select the tasks which should be performed with the files of the project.

   For more information about customizing the settings of batch processing, see 4.2.3. “Customizing Batch Processing” on page 26.

8. On the Summary page view the brief information about the created project.

9. On the Preparation page wait till the process of creating the project is finished.

   After the project has been successfully created, if necessary, update the template on which you based the project with the settings used for the current project, or create a new project template based on this project.
4.2.1. Customizing PROMT Translator (PTS)

10. If the project has been successfully created, click Close to exit the wizard.

   The Close button is not active until the project is created. If a project was not created due to errors in the tasks, this button remains inactive. Click Back to change the settings and restart the creating process.

4.2.1. Customizing PROMT Translator (PTS)

To customize main translation settings, select a provider on the Translation Resources page and click Settings.

On the Connection Settings tab of the Settings dialog box specify the PTS connection string and, if necessary, authentication data which are used for connecting to PTS, or proxy server data, if you connect to PTS via a proxy server.
To get the PTS connection string please address to your server administrator. Administrator, in turn, can get it from IIS.

The PTS connection string should be in the following format: http://<server name or IP-address>/<name of XLIFF-service web application>/ptsxlifftranslator.asmx.

To work with the PROMT for SDL Trados extension, you need the installed and customized XLIFF web service. The process of installation and customization of this component is described in PTS Administrator’s Guide.
4.2.2. Customizing Search in Translation Memory

On the Translation Settings tab of the Settings dialog box select the main translation settings that should be used in this project:

![Image of settings dialog box]

**Fig. 4.7. Customizing the main translation settings**

- PROMT Translator (PTS) provider supports translation for the language pairs included into the PTS set.
- If you had already customized connection to the PTS server for the PROMT Translator (PTS) provider, then this provider can be added only to those SDL Trados projects, at least one language pair of which is supported on the selected PTS server.
- For creating and editing translation profiles, use the PTS tools. For more information about working with translator, see the PTS User’s Guide.

4.2.2. Customizing Search in Translation Memory

To specify the settings for translation memory lookup and concordance searching during creating the project, select Search in the “Translation Memory and Automated Translation” group and specify the necessary options:

- “Minimum match value” — the degree of match that must exist between a source document segment and a translation memory segment in order for the segment translation to be offered as a match.
  - The default value is 70%.
- “Maximum number of hits” — the maximum number of translation memory matches that will be returned from a lookup
  - The default value is 5.
• “Look up segments in MT even if a TM match has been found”— enable this option, if you want to receive both translation memories and machine translation results. By default, SDL Trados Studio resorts to machine translation providers only if your selected translation memories do not generate any results.

Fig. 4.8. Customizing search in translation memory

For more information about other settings, see SDL Trados Studio User’s Guide or Help.

### 4.2.3. Customizing Batch Processing

To specify the settings of searching in translation memory for batch processing during creating the project, select Pre-translate Files in the Batch Processing group and specify the necessary options:

- “Minimum match value” in the Pre-translate Settings group — the degree of match that must exist between a source document segment and a segment in the translation memory, in order for the segment-translation in the translation memory to be applied to the document segment.

  You may want to set this at a higher figure than you would use when you are applying translation memory interactively during document translation. For example, you may want to pre-translate a file at a much higher value (for example, 100%) instead of the more usual figure of 75% used for interactive translation memory lookups.

- “Apply automated translation” in the “When no match found” group — if none of your selected translation memory generates a TM match that meets the “Minimum match value”, SDL Trados Studio
4.2.3. Customizing Batch Processing

inserts translation results from the machine translation providers listed on the “Translation Resources” page.

This option is available only if you already added machine translation providers.

For more information about other settings, see SDL Trados Studio User’s Guide or Help.
4.3. Editing Translation Results

To view the results of the preliminary batch translation, select Files in the left part of the screen and double-click the necessary file.

In the lower part of the opened window you can see the results of the preliminary batch translation with the help of enabled translation memories and PROMT Translator (PTS) provider.

If enabled translation memories did not generate any results and the segments were translated by the translation provider, the pane with translation looks like the following:
4.3. Editing Translation Results

If some segments were found in the enabled translation memories and other were translated by the translation provider, the pane with translation looks like the following:
In the Translation Results pane you can compare all variants of translation of the current segment, received from translation memories and translated by the provider, and select the most appropriate translation.

An icon between the source and target segments displays the actual match value for the segment from the translation memory, or AT (Automated Translation). If you place the mouse cursor on the icon, a tooltip appears which displays the details of translation:

- **Status** — current status of the segment;
- **Origin** — source of translation (Translation Memory or Automated Translation);
- **System** — TM name or the name of translation provider;
- **Score** — percent of match.

You can edit the results of translation in interactive mode or save them in bilingual format and send to external editor for reviewing.

- To save the translation of the document in a file, select File > Save Target As (Shift+F12) and specify the file name.
4.3. Editing Translation Results

- To save the results of translation in bilingual format, click Batch Tasks and select “Export for External Review”.
  - The thus saved file can be sent for reviewing to the external editor who may not have the installed SDL Trados Studio.

- To load the edited by the external editor bilingual file, click Batch Tasks and select “Update from External Review”.
4.4. Updating Translation Memory

To update the translation memory with translations from the active document, do the following:

1. Click Batch Tasks on the Home tab of the Projects view and select Update Main Translation Memories. Follow the onscreen instructions:

2. On the Translation Memory Updates page specify the settings:
   - select which translations should be added to the translation memory. This defaults to segments that are fully translated and approved;
   - select whether the translation should be added as new translation units or replace an existing translation unit.

3. Click Finish and wait till the process of translation memory updating is finished.

4. Click Close.

   Before updating the translation memory make sure that Update checkbox is checked in the “Translation Memory and Automated Translation” group of the project settings.
4.4. Updating Translation Memory

For more information about working with translation memories, see SDL Trados Studio User’s Guide or Help.